HomeХобби и стильRelated VideosMore From: Rob Cubbon

Facebook Preview – Posting Links Correctly (using Yoast SEO and Facebook Debugger)

93 ratings | 11781 views
http://robcubbon.com/go/yfbc This is how you post links in Facebook so that the image appears (as well as the title and the description). It's easy if you use WordPress and Yoast SEO but you don't have to . You have to ensure you have the correct Open Graph Metadata. I will also show you a trick involving Facebook Debugger. https://developers.facebook.com/tools/debug/ Do you tear your hair out everytime you post a link in Facebook and wait and wait and it doesn't appear with a nice big image? This is the video tutorial for you!
Html code for embedding videos on your blog
Text Comments (40)
Vlad Caluș (5 months ago)
Hey, Rob! That's a really great video - our team also shared a few tips on how to post link correctly using Facebook Debugger and how to solve the errors that are appearing, I hope this helps - https://blog.planable.io/facebook-link-debugger/
DEBAJYOTI BISWAS (5 months ago)
Its not working ! have a look cheeking the link http://www.saveindianculture.com/2018/08/07/election-2019/
DEBAJYOTI BISWAS (5 months ago)
Rob Cubbon so in case for video, untill the snapshot of the videyo opening I will use for feature image or add to media section in the particular post, the video preview would not show in facebook
Rob Cubbon (5 months ago)
It does still work Debvajyoti Biswas. I've just run your link through the Facebook Debug Tool and it says This URL hasn't been shared on Facebook before.Fetch new information https://developers.facebook.com/tools/debug/sharing/?q=http%3A%2F%2Fwww.saveindianculture.com%2F2018%2F08%2F07%2Felection-2019%2F%EF%BB%BF So you didn't carry out the task that was explained in the video properly.
toxiSrb (11 months ago)
There is an easy way to personalize title, description, image... Just go to customizefb.com, paste a link you want to share and there you can type in any title, description and image. Then you get a new link which you share on Facebook and this one will contain your customized title etc. When people click on this share they automatically go to your page.
Sue J (1 year ago)
I've just installed and configured Yoast exactly to sort out this issue and I'm getting the missing image and error with every single post the first time around. Yes, when I try it a second time it works (hooray!) but our audience wouldn't know to do that. If someone else tries to share a post, will they also get an error the first time around?
Ya Jagoff (1 year ago)
very helpful.. no, this is not a spam comment. Wanted to let you know that this was very helpful for sure. Each daily blog post I struggle with getting folks to follow the funnel into the blog post. Many times they just like or comment on the photo associated with the link and don't click through. thank you
Sabib Bhuiyan (1 year ago)
under post link besides it shows ""by Rob Cubbon "" how to do that ?
Corine van Oeveren (1 year ago)
Hi Rob! How did you add the 'BY ROB CUBBON' line in your post?
Corine van Oeveren (1 year ago)
Oh no!! Thanks for your quick reply though Rob....
Rob Cubbon (1 year ago)
sorry this was a setting in Facebook I did ages ago and I've forgotten it! :)
Juan José Tejada (1 year ago)
Hi!! I have my blog on JIMDO, and for the past 4 weeks i have been looking on how to put the "BY ------" Next to my link. Just like yours on facebook do you know how to do it?
Rob Cubbon (1 year ago)
sorry this was a setting in Facebook I did ages ago and I've forgotten it! :)
Miguel Henry (2 years ago)
Does this perform well on Facebook still? It seems like Facebook doesn't like links, when I post them they don't get many likes or interaction because of the fact that Facebook wants to keep people in Facebook.
Miguel Henry (2 years ago)
Ok. Thanks for answering.
Rob Cubbon (2 years ago)
Sure, that's true. This video is only about the way the links look when they are presented in the news streem. It's nothing to do with how many times they show up.
Amber Blake (2 years ago)
when i go to fb debugger i get this error: The 'fb:app_id' property should be explicitly provided, Specify the app ID so that stories shared to Facebook will be properly attributed to the app. Alternatively, app_id can be set in url when open the share dialog. any ideas?
Rob Cubbon (2 years ago)
+Amber, not really sure what that error is about tbh. But I always get the odd error, the important point is whether the post appears OK in Facebook and the other social platforms or not. So, are your links displaying ok?
Marz Seumalii (2 years ago)
OMG! thank you! thank you! thank you! been trying to figure how to do this for ages and couldnt find a proper video that was easy enough to understand! cheers!
h2odivemaster (2 years ago)
When I share a post it has both the metadat description in the little box with the image but above it automatically shows the first few lines of the story. I am using yoast but also using publicize to share it onto facebook. Do you know what the problem might be ? It seems like a lot of extra steps you need to take to share each post to facebook
h2odivemaster (2 years ago)
Sorry I followed your instructions and it worked perfectly thank you
thanks....
Rob Cubbon (2 years ago)
pleasure
Yves Lajoie (3 years ago)
Thank you Rob. Simple and helpful.
Rob Cubbon (3 years ago)
+Yves Lajoie my pleasure
Thanks Rob, your tutorial was very helpful this bug was driving crazy and pissing me off.
Rob Cubbon (3 years ago)
+Montserrat robledo hernandez great, glad it helped
Lori Folz (3 years ago)
Hello Rob. Can we see the same results if we use Blogger instead of Wordpress?
Lori Folz (3 years ago)
Looking at Yoast just now. It is a plug in for Wordpress so am thinking it cannot be used with Blogger. Is this correct?
rachkat926 (3 years ago)
Hi Rob -- what about videos? I have Yoast installed, and when I embed a video on a WP post, Facebook ALWAYS pulls in the video, rather that letting me post a regular link post. There's no workaround I can find. I've uploaded a feature image, unchecked "disable video" in the Yoast module, tried to override the default Facebook photo, and nothing. Facebook Debugger is no help either. Thanks in advance for any help!
Rob Cubbon (3 years ago)
+rachkat926 how have you embedded the video in the WP post, a YouTube video? What do you mean by "FB pulls in the video", they show the video thumbnail? If so, I have no idea what FB is doing in your case. They usually hate YT!
Anna Levina-Zubarev (3 years ago)
Hey Rob, It's truly great that I found your video here on Youtube, as there isn't much information out there about it, especially knowing so many people having the same issue with this! Anyhow, after following your advice here, I used the Debuger, then pressed to "Fetch/Scrape new info" the image is still NOT working and I m really not sure what to do from this point. IF I cannot use images to share my content with my followers, what's the point of sharing then..... you know what I mean. So if you have any latest tips or updates for me - those would come really handy for me. Thanks in advance if you can respond to this.
Anna Levina-Zubarev (3 years ago)
Thanks +Rob Cubbon I think I was able to fix this issue by disabling Yoast SEO plugin which was causing that issue in a first place. FB Open Graph Meta was enabled and I did had all the setting filled out too.   I had to disable Yoast SEO and Enable "All pack seo" plug in that allowed for my images to be shared and appeared correctly. Also, I use Canva.com which already has all the presets for the correct image optimization.  I'll be happy to connect with you here regardless.  I added you to my circles in G+  and might send you a direct email if I might need you again ;-)  Thanks a lot for your quick response! 
Rob Cubbon (3 years ago)
+Anna Levina-Zubarev Hi Anna, it's probably to do with the way you've got your website set up . Do you have the Facebook Open Graph Meta Data in your pages' HTML? Do you have Yoast SEO set up? Do you have a nice big image in the post? It could be anything. If you like could you send me an email through my site http://robcubbon.com/contact I could take a look at it for you
El canal del Yorgio (3 years ago)
Hi Rob. I follow all your step, but still apears the wrong post on facebook, without thumbnail image. When i use the Yoast SEO plugin on WordPress, facebook debugger displays the next message:" Errors that must be fixed: Meta Tags in Body". If you need more information like url website, i can send you on a private message. Thanks and cheers from Chile!
Rob Cubbon (3 years ago)
+El canal del Yorgio OK
El canal del Yorgio (3 years ago)
+Rob Cubbon, can i send you a private message? its a institutional website and i must be very carefull with the information. Thanks!
Rob Cubbon (3 years ago)
+El canal del Yorgio yes, please send me the URL
fairsosworld (3 years ago)
Hi Thank you great video the facebook debugger was what I needed ;D
Rob Cubbon (3 years ago)
+fairsosworld my pleasure. Yes, I use it all the time!

Would you like to comment?

Join YouTube for a free account, or sign in if you are already a member.